Moodle now supports both LTI 1.0 and LTI 2.0 integration.


Both integrations support:

  • Single Sign On from Moodle to Pebble+
  • Single Sign On from Moodle to ATLAS
  • Create PebblePad accounts upon single sign on for new users
  • Create assets based on content item activity links (Moodle 3.2 and above)
  • Populate an ATLAS workspace members based on course enrollment (via SSO)


Only LTI 2.0 supports:

  • Pass grades back to Moodle
  • Populate an ATLAS workspace members based on course enrollment (via Memberships service)


You should only consider using the LTI 1.0 integration if you are using an outdated version of Moodle or if your Moodle install is hosted by a third party and the following issues have not been resolved:


You should only consider using the LTI 2.0 integration if you are self-hosting Moodle or your host is able to make a code change to Moodle core as the above Moodle issues are preventing a complete level of integration with our platform.


You can download the current Moodle LTI 1.0 and Moodle LTI 2.0 documentation here: